• Welcome to the ShrimperZone forums.
    You are currently viewing our boards as a guest which only gives you limited access.

    Existing Users:.
    Please log-in using your existing username and password. If you have any problems, please see below.

    New Users:
    Join our free community now and gain access to post topics, communicate privately with other members, respond to polls, upload content and access many other special features. Registration is fast, simple and free. Click here to join.

    Fans from other clubs
    We welcome and appreciate supporters from other clubs who wish to engage in sensible discussion. Please feel free to join as above but understand that this is a moderated site and those who cannot play nicely will be quickly removed.

    Assistance Required
    For help with the registration process or accessing your account, please send a note using the Contact us link in the footer, please include your account name. We can then provide you with a new password and verification to get you on the site.

Car help needed

Joined
Nov 13, 2006
Messages
9,395
Location
Westcliff
Hi

I have had a problem my renault clio where for weeks it will be fine then all of a sudden a orange light appears which looks a little like the heater plug symbol. it basically doesn't allow to get much over 30mph and getting upto that speed takes a lot of time. it was a case of turning the engine off and then back on again and then after a while it would be ok again. Its getting worse now though and not going off.

After doing some research on the internet I have found out this is a very common problems with clios. The problem is theirs no fixed solution and its kind of trial and error but thats means a lot of money being spent at garages.

Anyone else come across this problem? would be really helpful you could let me know

thanks
 
Top